iRaiser - iDEAL experiencing major outage – Incident details

All systems operational

iDEAL experiencing major outage

Resolved
Degraded performance
Started 9 days agoLasted 19 minutes

Affected

Community Fundraising Platform

Degraded performance from 2:50 PM to 3:08 PM

Digicollect

Degraded performance from 2:50 PM to 3:08 PM

Donation forms app

Degraded performance from 2:50 PM to 3:08 PM

CRM

Degraded performance from 2:50 PM to 3:08 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have identified a full disruption external to our platform affecting iDEAL payments. You will see a decline in successful payments as consumers are unable to pay using this payment method. We are in close contact with the Payment Service Providers to resolve the issue and will provide updates as they become available.